HTC Desire S Para hablar del Desire S de HTC

Viejo 01/06/12, 12:25:00

Stuart M. Hombre Stuart M. no está en línea
Miembro del foro
Fecha de registro: jun 2011
Mensajes: 456

Posible solución al problema del chip eMMC

No sé si alguien ya ha comentado aquí esto, pero está bien tenerlo a mano por si acaso.

He hecho un copia - pega de XDA, en el siguiente enlace tenéis el hilo completo.


All Desire S users should know about the infamous error message:

E:Can't mount /cache/recovery/command
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
this is the so called eMMC fried chip, etc.. This is actually the "cache" partition being corrupted..

I myself have already received this error NUMEROUS times when tinkering with my phone..

The fix..?

Here's my method:
1. remove the battery for 30secs to 1 minute and putting it back in

2. boot directly to your bootloader, then go to recovery

3. If you haven't received the errors, your cache will be formatted to EXT3, try formatting it to ext4 if need be

4. I wipe everything (all partitions) including dalvik cache and battery stat

5. flash your rom again, cross your fingers and hope for the best..
Based on experience: Even the RUUs will tell you to unplug your battery for 3secs if RUU had some problem.

Some additional info:
Originally Posted by Skanob
You should be able to change your recovery without any problem if your s-off or unlocked 2.xx.xx hboot s-on.

1. Get 4ext recovery.img

2. connect phone on fastboot

3. In cmd use these command to push the recovery image:

fastboot flash recovery D:\recovery.img (<- should be directory of 4ext recovery image)

fastboot reboot-bootloader

Now you should have 4ext recovery.


I do not think that you can use fastboot flash whatewer without an engineering bootloader (requires s-off) or push images with adb without su (requires rooting). This is the point of all the guides and tutorials around here...
You actually can.. Check my sig.. I have already flashed a stock recovery then back to 4EXT many times.. I am on OFFICIAL HBOOT from the 2.10.401.4 update..

flashing OFFICIAL RUUs prior to latest hboot didn't work for me as the HBOOT seems to be un-writable to old HBOOTs. I haven't tried revolutionary's 6.xx.xx HBOOT though..

I am on unrooted STOCK RUU when I tried to flash the update forcefully. HBOOT and RECOVERY got updated so got me stock on HTC logo (without the "quietly brilliant") means ROM is not booting.

That is the method I used to revive my phone.

"Unlocking" my S-ON could've helped me..
Originally Posted by Skanob
Originally Posted by amidabuddha
Ok taking my words back And how do you did this? You flashed the Stock 2.10.401.4 ROM over you bricked phone and it worked? (overwritted the revolutionary hboot or which version was it before?).
To make the long story short:

I stupidly get the firmware.zip file inside the ota file. That file had the latest hboot, recovery, and others. I renamed it to the correct pgxxximg.zip (cant remember the correct filename, currently drinking ) to flash it from bootloader.

Everything went well. Everything inside the file updated the corresponding file/partition/image to my phone. Hence letting me be stuck to the "locked" hboot 2.xx.xx s-on. ROM wouldn't boot as I said.

Being on the "locked" state wouldn't allow me to flash anything on the phone as far as i can remember. While writing, it will say has its unsuccessful.

But "unlocking" the hboot let me flash the recovery.
Responder Con Cita
Gracias de parte de:
Sponsored Links

Estás aquí
Regresar   Portal | Indice > Zona HTC > Otros modelos de HTC con Android > HTC Desire S


Hora actual: 08:42:18 (GMT +1)

User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.