PDA

Ver la Versión Completa : Error INSTALL_FAILED_MISSING_SHARED_LIBRARY Google ADK


albertoMar
26/11/11, 11:14:52
Buenos días,

Anteriormente tenía un Nexus One, con Android 2.3.4, pero el teléfono se me rompio y compre otro igual de segundamano. Este último viene con la fantástica ROM SuperAosp-ST@-Nexus-8.4, que es una verdadera delicia de ROM, pero tengo un pequeño problema. Como sabran para poder utilizar Google ADK el dispositivo tiene que tener al menos la versión 2.3.4, en mi antiguo Nexus podía hacer aplicaciones usando el ADK sin ningún problema, pero cuando intente ejecutar la misma aplicación en este último Nexus con la ROM ya dicha, me aparecio el siguiente error:

Installation error: INSTALL_FAILED_MISSING_SHARED_LIBRARY

Después fui al LogCat y encontré lo siguiente:

Package com.joystick requires unavailable shared library com.android.future.usb.accessory;

En la documentación de google, (No me deja poner links, pero si mirais la documentación es en USB Accesory) se puede ver como para android 2.3.4, se tiene que utilizar esa librería, es más como ya he dicho con mi antiguo Nexus y la ROM oficial de google no había problema.

Busque el problema en internet y en los foros de stackoverflow, la gente reportaba el mismo problema porque intentaban instalar la aplicación en terminales con versiones de android más antiguas.

Pues este es mi problema, la ROM me gusta demasiado como para volver a la oficial de google. He intentado buscar la misma ROM que tengo instalada para ver si hay alguna nueva versión o incluso reinstalar la que tengo, pero no he encontrado nada ¿sigue funcionando el proyecto para esta ROM?. Según he leído, en este foro SuperAtmel tenía un subforo dedicado para sus ROMs, pero no lo he encontrado, ¿alguien sabe algo de esta ROM? ¿y de como solucionar el problema?

A continuación, pongo más información sobre mi teléfono:
Versión Android: 2.3.4
Número de compilación: GRJ22
Versión del kernel: 2.6.37.4-SuperAosp_HAVS-CFS
Versión MOD/ROM: SuperAosp-ST@-Nexus-8.4

Este error me lo dio y no tenía ninguna aplicación instalada que no viniera con la ROM.

Espero haberme explicado bien, y muchas gracias.

silverbot2
26/11/11, 12:21:56
Buenos días,

Anteriormente tenía un Nexus One, con Android 2.3.4, pero el teléfono se me rompio y compre otro igual de segundamano. Este último viene con la fantástica ROM SuperAosp-ST@-Nexus-8.4, que es una verdadera delicia de ROM, pero tengo un pequeño problema. Como sabran para poder utilizar Google ADK el dispositivo tiene que tener al menos la versión 2.3.4, en mi antiguo Nexus podía hacer aplicaciones usando el ADK sin ningún problema, pero cuando intente ejecutar la misma aplicación en este último Nexus con la ROM ya dicha, me aparecio el siguiente error:

Installation error: INSTALL_FAILED_MISSING_SHARED_LIBRARY

Después fui al LogCat y encontré lo siguiente:

Package com.joystick requires unavailable shared library com.android.future.usb.accessory;

En la documentación de google, (No me deja poner links, pero si mirais la documentación es en USB Accesory) se puede ver como para android 2.3.4, se tiene que utilizar esa librería, es más como ya he dicho con mi antiguo Nexus y la ROM oficial de google no había problema.

Busque el problema en internet y en los foros de stackoverflow, la gente reportaba el mismo problema porque intentaban instalar la aplicación en terminales con versiones de android más antiguas.

Pues este es mi problema, la ROM me gusta demasiado como para volver a la oficial de google. He intentado buscar la misma ROM que tengo instalada para ver si hay alguna nueva versión o incluso reinstalar la que tengo, pero no he encontrado nada ¿sigue funcionando el proyecto para esta ROM?. Según he leído, en este foro SuperAtmel tenía un subforo dedicado para sus ROMs, pero no lo he encontrado, ¿alguien sabe algo de esta ROM? ¿y de como solucionar el problema?

A continuación, pongo más información sobre mi teléfono:
Versión Android: 2.3.4
Número de compilación: GRJ22
Versión del kernel: 2.6.37.4-SuperAosp_HAVS-CFS
Versión MOD/ROM: SuperAosp-ST@-Nexus-8.4

Este error me lo dio y no tenía ninguna aplicación instalada que no viniera con la ROM.

Espero haberme explicado bien, y muchas gracias.

Formatea y instálate la ultima de Jrsoft 7.2 con Android 2.3.7 que es mucho mejor que esa!:cry:

albertoMar
29/11/11, 18:44:51
Gracias por contestar, probaré la ROM que comentas, aunque la actual que tengo me gusta mucho