PDA

Ver la Versión Completa : Tutorial Xpoxed funcional


FERROS73
13/04/16, 12:21:10
Hola compañeros,

En Xda ya han conseguido que Xposed sea funcional para los Huawei.

Os hago una traducción con las particularidades de nuestro Mate S y con la configuración que me ha funcionado a mí. Yo actualmente tengo la versión 114 con Android 5.1.1 y este tutorial es para utilizar en esta versión de android.


En el enlace también están los archivos para hacerlo en android 5.0 y 6.0 y entiendo que funcionará también.


Empezamos:


1 - Descargar Xposed de los links que vienen en el enlace de XDA del post original. Tenéis que descargar en nuestro caso los correspondientes al arm64, tanto el instalador como el desinstalador(importante).


2 - Modificar la carpeta /system/build.prop. En esta carpeta hay que eliminar la línea siguiente:


ro.config.hwtheme=1 y ro.config.hwtheme=2 en el caso de que aparezcan cualquiera de las dos.

y añadir las siguiente líneas:

ro.config.hwtheme=0
ro.config.hw_theme=0


3 - Instalar Xposed Installer 3.0 alpha4.apk.


4 - Reiniciar en modo recovery y flashear el archivo Xposed-v82-sdk-arm64.zip. Después hacer Wipe cache y Dalvik porque si no entrará en bootloop.


5 - Iniciar el teléfono y listo.

Atención – El teléfono puede tardar más de 20 minutos en iniciar así que no os asustéis.

En caso de error:
Si entrara en bootloop o no funcionara el framework sólo tenéis que volver a entrar al recovery y flashear el desinstalador que hemos descargado anteriormente y volver a hacer Wipe cache y Dalvik y el teléfono volverá a sus estado anterior sin ningún problema.


Como siempre espero que sea útil y un placer echaros una mano en lo que pueda.

Fuente: XDA http://forum.xda-developers.com/android/general/guide-workaround-running-xposed-t3338765 (http://forum.xda-developers.com/android/general/guide-workaround-running-xposed-t3338765)

julianceed
13/04/16, 13:04:43
En XDA esta todo amigo ! Gracias por traerlo a HTCMania

Big Z
13/04/16, 19:15:41
Yo de momento no voy a "cacharrear" con el Mate S, no sé cuanto aguantaré, pero se agradece el trabajo del compañero FERROS73.

Saludos.

kruuuuuuum
15/05/16, 13:06:00
Alguien lo ha probado en el 6.0??

julianceed
29/07/16, 16:24:23
Alguien lo ha probado en el 6.0??

Yo lo he intentado pero no arranca se queda en el logo de Huawei, luego vi que habia que quitar lineas en el build.pro y resulta que no estaban esas lineas... a mi no me ha funcionado.

sebastassara
29/07/16, 18:17:37
Alguien lo ha probado en el 6.0??

Lo probé con las versiones B321 y B361 y funciona perfectamente

julianceed
30/07/16, 21:54:33
Lo probé con las versiones B321 y B361 y funciona perfectamente
Tuviste que borrar alguna linea del builds. Pro?

mautryx
02/08/16, 22:09:13
Lo probé con las versiones B321 y B361 y funciona perfectamente

hola, podrias decirme como actualizaste a version b362? gracias

sebastassara
02/08/16, 22:24:33
Tuviste que borrar alguna linea del builds. Pro?

No, se entra a system/emui/base/pro/local.prop y se edita la línea ro.config.hwtheme=1
y la cambias por 0 envés de 1.

sebastassara
02/08/16, 23:18:26
hola, podrias decirme como actualizaste a version b362? gracias
Claro, primero estando en la versión B321 regrese al recovery de stock y restaure la carpeta system (ya que había hecho modificaciones en system y al actualizar verifican que esa carpeta este "virgen") luego me fui a buscar actualizaciones en configuración y me salió la update B361, luego se actualizó sin problemas.

mautryx
11/08/16, 17:23:21
Claro, primero estando en la versión B321 regrese al recovery de stock y restaure la carpeta system (ya que había hecho modificaciones en system y al actualizar verifican que esa carpeta este "virgen") luego me fui a buscar actualizaciones en configuración y me salió la update B361, luego se actualizó sin problemas.
Hola,bro, teolestaria mucho subir un tutorial. Mi b321 la baje de huawei españa.

Enviado desde mi CRR-L09 mediante Tapatalk