PDA

Ver la Versión Completa : Moto 360 y android wear en el P8


PaK_HTCmania
21/06/15, 22:01:48
Ya muchos sabréis el problema que tiene el P8 con los permisos de notificación con Android wear y otras aplicaciones..que después de otorgarlos al poco se desactivan y dejan de llegar. Bueno, concretamente he podido solucionarlo con el moto360 y quizás sirva también para otros smartwatch.

Como muchos sabréis ya está llegando la actualización a 5.1.1. Y a los que aún no hay una manera sencilla de forzar que salte dicha actualización.

Ya que como con el P8 no se lleva bien lo que haremos es con otro teléfono (P7 en mi caso) forzar la actualización a 5.1.1. Es tan sencillo como desvincular el 360 del Bluetooth(si es que lo estaba) y desinstalar android wear y motorola conect. Ahora cogeremos el 360 y en ajustes del sistema lo reestableceremos. Mientras este se restaura instalaremos android wear nuevamente en nuestro 2o teléfono. Pero no lo ejecutaremos. Esperaremos a que termine el 360 de restablecerse y que al iniciarse él nos pide que instalemos dicha aplicación. No activéis ni vinculéis manualmente el smartwatch ok? Lo iréis haciendo con Android wear que os lo va pidiendo paso a paso. Cuando ya tengáis todo andando iréis a los ajustes del 360 y en actualizaciones miraremos si hay disponible la nueva versión para descargar. Tened en cuenta que hay que tenerlo con el 80 o 90% de batería para descargarla. Si no os ha saltado tendréis que repetir el proceso de reestablecer el 360..desinstalar Android wear..desvincularlo del Bluetooth..hasta que nos salga.

Una vez tengamos todo andando con el 360 en 5.1.1 lo que he echo es volver a restablecerlo y mientras iba instalando Android wear en el P8..y volver al proceso que ya he explicado.

Se ve que con Android wear 5.1.1 el P8 sí funciona correctamente y no se desactivan los permisos de las notificaciones.. al menos yo llevo todo el día funcionando perfectamente y sin hacer ningún rollo raro en la configuración ni nada parecido.

Comentaros que estoy en la versión del P8 B132 pero era imposible echar a andar el 360 con esta versión sin haberlo actualizado..así que en la B110 supongo que funcionará si conseguís actualizar el smartwatch a 5.1.1

Perdón por la extensión y espero haber servido de ayuda a algunos..que compañeros que estaban interesados en este precioso terminal lo descartaron directamente al conocer este problema. Aunque era de suponer que se solucionaría más pronto que tarde.

Y eso es todo..saludos de un feliz usuario de P8 con moto360 y talkband b2 :ok:

reguart
30/10/15, 14:03:07
Ya muchos sabréis el problema que tiene el P8 con los permisos de notificación con Android wear y otras aplicaciones..que después de otorgarlos al poco se desactivan y dejan de llegar. Bueno, concretamente he podido solucionarlo con el moto360 y quizás sirva también para otros smartwatch.

Como muchos sabréis ya está llegando la actualización a 5.1.1. Y a los que aún no hay una manera sencilla de forzar que salte dicha actualización.

Ya que como con el P8 no se lleva bien lo que haremos es con otro teléfono (P7 en mi caso) forzar la actualización a 5.1.1. Es tan sencillo como desvincular el 360 del Bluetooth(si es que lo estaba) y desinstalar android wear y motorola conect. Ahora cogeremos el 360 y en ajustes del sistema lo reestableceremos. Mientras este se restaura instalaremos android wear nuevamente en nuestro 2o teléfono. Pero no lo ejecutaremos. Esperaremos a que termine el 360 de restablecerse y que al iniciarse él nos pide que instalemos dicha aplicación. No activéis ni vinculéis manualmente el smartwatch ok? Lo iréis haciendo con Android wear que os lo va pidiendo paso a paso. Cuando ya tengáis todo andando iréis a los ajustes del 360 y en actualizaciones miraremos si hay disponible la nueva versión para descargar. Tened en cuenta que hay que tenerlo con el 80 o 90% de batería para descargarla. Si no os ha saltado tendréis que repetir el proceso de reestablecer el 360..desinstalar Android wear..desvincularlo del Bluetooth..hasta que nos salga.

Una vez tengamos todo andando con el 360 en 5.1.1 lo que he echo es volver a restablecerlo y mientras iba instalando Android wear en el P8..y volver al proceso que ya he explicado.

Se ve que con Android wear 5.1.1 el P8 sí funciona correctamente y no se desactivan los permisos de las notificaciones.. al menos yo llevo todo el día funcionando perfectamente y sin hacer ningún rollo raro en la configuración ni nada parecido.

Comentaros que estoy en la versión del P8 B132 pero era imposible echar a andar el 360 con esta versión sin haberlo actualizado..así que en la B110 supongo que funcionará si conseguís actualizar el smartwatch a 5.1.1

Perdón por la extensión y espero haber servido de ayuda a algunos..que compañeros que estaban interesados en este precioso terminal lo descartaron directamente al conocer este problema. Aunque era de suponer que se solucionaría más pronto que tarde.

Y eso es todo..saludos de un feliz usuario de P8 con moto360 y talkband b2 :ok:
Hola!

Resucito tu post pues desde ayer tengo el p8 y me ocurre lo de las notificaciones.

Observo que pasa cuando bloqueo el movil y lo desbloqueo. Si en ajustes/bloqueo de pantalla desactivo "solicitar desbloqueo del telefono para usarlo" funciona bien, no se desactivan las notificaciones en android wear, pero claro, no es una solución definitiva ya que me gusta llevar patrón.

Leyendo tu gran post me imagino que tendrer que probar a actualizar la version de software, veo que llevo la b118, actualizaré a la más reciente.

Ha pasado tiempo desde tu post, me recomiendas alguna más nueva que la que comentas en la que te funcione?

Mimovil es libre de orange, en el reloj ya esta la 5.1.1.

Muchas gracias!

Enviado desde mi HUAWEI GRA-L09 mediante Tapatalk

PaK_HTCmania
30/10/15, 15:00:06
Yo pondría la B200

La tienes en el listado oficial en el apartado de roms y desarrollo

Ten en cuenta que cada vez que quieras que funcione y se enlace y sincronice todo correctamente tendrás que restablecer de fábrica el SmartWatch y volver a desinstalar e instalar Android wear. Es un coñazo pero si no no enlaza ni a la de tres

MHARKER
30/10/15, 18:39:59
Con la TalkBand 2 no has tenido ningún problema entonces?...

reguart
30/10/15, 22:29:04
Yo pondría la B200

La tienes en el listado oficial en el apartado de roms y desarrollo

Ten en cuenta que cada vez que quieras que funcione y se enlace y sincronice todo correctamente tendrás que restablecer de fábrica el SmartWatch y volver a desinstalar e instalar Android wear. Es un coñazo pero si no no enlaza ni a la de tres


Bueno, hago eso cada vez que cambio de movil o de rom, es el procedimiento habitual no?

Me estoy iniciando el móvil y me queda mucho por aprender y descubrir, tengo el GRA-L09 y veo que no está la b200, solo llega a la b170.

PaK_HTCmania
31/10/15, 00:22:18
Con la TalkBand 2 no has tenido ningún problema entonces?...



La B2 perfecta

PaK_HTCmania
31/10/15, 00:23:13
Bueno, hago eso cada vez que cambio de movil o de rom, es el procedimiento habitual no?

Me estoy iniciando el móvil y me queda mucho por aprender y descubrir, tengo el GRA-L09 y veo que no está la b200, solo llega a la b170.




Sí, pero es un coñazo..

reguart
31/10/15, 01:23:47
Sí, pero es un coñazo..

He actualizado a la b200 y ahora en principio funciona bien.

Me ha pasado una cosa curiosa... lo he actualizado por el método de los vol+, vol+ y power, y ha comenzado a actualizar. De repente (no sé que porcentaje llevaba, aunque creo que todo o casi todo) ha dado un error, que pusiera un paquete correcto para actualizar, he reiniciado y la ha instalado correctamente.

Curioso.

Muchas gracias PaK_Huawei!!!

PaK_HTCmania
31/10/15, 11:08:23
He actualizado a la b200 y ahora en principio funciona bien.

Me ha pasado una cosa curiosa... lo he actualizado por el método de los vol+, vol+ y power, y ha comenzado a actualizar. De repente (no sé que porcentaje llevaba, aunque creo que todo o casi todo) ha dado un error, que pusiera un paquete correcto para actualizar, he reiniciado y la ha instalado correctamente.

Curioso.

Muchas gracias PaK_Huawei!!!



A veces pasa.

Comprueba que no hayas perdido la posibilidad de seleccionar 4G en los ajustes de Redes.

Si es así hay que pasarle un archivo Cust, que corrige ese pequeño error.. y formateará la memoria interna otra vez.. así que si quieres ir haciendo también la copia de seguridad..

reguart
31/10/15, 11:14:26
A veces pasa.

Comprueba que no hayas perdido la posibilidad de seleccionar 4G en los ajustes de Redes.

Si es así hay que pasarle un archivo Cust, que corrige ese pequeño error.. y formateará la memoria interna otra vez.. así que si quieres ir haciendo también la copia de seguridad..
Pues veo que en ajustes/opciones de red al darle a red no hace nada, no abre el sub menú; he quitado la wifi y el 4g me llega bien, pero al darle a red se va la cobertura y vuelve como si desactivara y activara los datos.

No me molesta mucho ya que nunca accedo a ese menú, pero claro, no me gusta que falle.

Te agradecería me indicaras donde está ese archivo CUST, que imagino instalare a través del recogerá twrp.

Te agradezco mucho la ayuda.

Enviado desde mi HUAWEI GRA-L09 mediante Tapatalk

PaK_HTCmania
31/10/15, 11:49:23
Pues veo que en ajustes/opciones de red al darle a red no hace nada, no abre el sub menú; he quitado la wifi y el 4g me llega bien, pero al darle a red se va la cobertura y vuelve como si desactivara y activara los datos.

No me molesta mucho ya que nunca accedo a ese menú, pero claro, no me gusta que falle.

Te agradecería me indicaras donde está ese archivo CUST, que imagino instalare a través del recogerá twrp.

Te agradezco mucho la ayuda.

Enviado desde mi HUAWEI GRA-L09 mediante Tapatalk







Mira, seguimos aquí ya que a este compi le pasa exactamente lo mismo que a ti:


http://www.htcmania.com/showthread.php?t=1028887&page=8

reguart
01/11/15, 11:38:21
Solucionado! Muchas gracias, por cierto, me gusta la funcion desbloqueo inteligente, si tienes el reloj activado se desbloquea sin patrón, pero si no lo detecta lo pide. Muy cómodo.

Enviado desde mi HUAWEI GRA-L09 mediante Tapatalk

PaK_HTCmania
01/11/15, 20:46:05
Si, esa opción es genial

reguart
02/11/15, 18:30:19
Decir que funciona pero no es perfecto, se me desconecta bastante el reloj y a veces no llegan las notificaciones.

Estoy trasteando y he comprobado que al separarme del móvil el reloj se desconecta (como es lógico) pero no vuelve a conectarse al unirse si no desactivo y activo el bluetooth; después de algunas pruebas reiniciando ambos dispositivos, he quitado "Android wear" como aplicación protegida (la había puesto) y decir que parece que funciona. Seguiré con las pruebas...