PDA

Ver la Versión Completa : Algunos programas no funcionarán en Android 1.5


JamworkS
24/04/09, 09:13:43
Si leemos la siguiente noticia (en inglés) veremos que pone que el equipo de desarrollo del SDK 1.5 ha encontrado soft en el Market que a ciencia cierta no funcionará en el 1.5.

Si queréis echar una vistacillo, aquí os va:

http://www.talkandroid.com/949-android-cupcake-15-update-apps/

vierco
24/04/09, 12:01:33
Bueno, esperemos que las pérdidas no sea importantes...

kakadeluxe
24/04/09, 13:16:35
Eso que cuenta ya lo sabia, he probado las ROM de Haykuro y Duke que son de la 1.5 y he visto que muchos programas no funciona bien o casca.

JamworkS
24/04/09, 13:57:03
Eso que cuenta ya lo sabia, he probado las ROM de Haykuro y Duke que son de la 1.5 y he visto que muchos programas no funciona bien o casca.
¿Qué es lo que sucede? ¿Directamente no funciona o es que se bloquea la PDA?

Un saludo,


JamworkS.

kakadeluxe
24/04/09, 15:22:36
¿Qué es lo que sucede? ¿Directamente no funciona o es que se bloquea la PDA?.Lo 1º que no funciona, sale un mensaje diciendo que no responde y, a veces, te da dos opciones uno de esperar (Wait) y otra de cerrarla (Force close).
De bloquear la PDA solo me ocurrió una vez y fue con el firmware 1.1 oficial. Si puede ocurrir que haga un reboot, reinicio, espontaneo pero no por un programa sino por el propio Android.

vierco
24/04/09, 16:33:14
Algo parecido se comenta que va a pasar con el 3.0 de iphone

migue85
05/05/09, 11:42:26
Es debido a que han actualziado el API de la version 1.1 a la 1.5. Algunas funciones quedan deprecadas o reciben un tratamiento distinto. En concreto algo importante fue el hecho de que eliminaran del API una clase bastante recurrida llamada AbsoluteLayout que si bien sigue estando soportada, puede dar problemas.
Entonces, cuando la aplicación muestra una incompatibilidad con la nueva version y ocasiona una excepcion en el movil, el sistema operativo captura la excepcion, mostrando el mensaje de error al usuario y forzando el cierre de la aplicacion.
Si bien los desarrolladores no lo tienen dificil para actualizar su aplicacion a la nueva version (los cambios son pocos) la tarea es un quebradero de cabeza y muy tediosa para proyectos grandes. Las mejoras del API son significativas pero crea controveria y algo de indignacion la supresion de clases tan usadas como el AbsoluteLayout, que ha dado dolores de cabeza a muchos desarrolladores. En concreto esa clase provee un modelo de vista de aplicacion bastante versatil pero no generico para todos los dispositivos por lo que se ha decidido eliminar su uso. Aquellos que hayan usado esa clase (la mayoria) tendran que recurrir a otros tipos de Layout para rehacer CASI POR COMPLETO su interfaz, lo cual da muchisimo por culo. No tenemos que pagar ese precio por desarrollar aplicaciones que dan versatilidad a su plataforma haciendoles el trabajo para que de la noche a la mañana adopten esa clase de medidas. QUe hagan bien el API desde el principio cojones! :D
Con cosas asi, algunas de las nuevas aplicaciones ni siquiera compilan en el entorno de programacion eclipse para Android. Eso si, se espera que las proximas versiones del API no tengan cambios tan incompatibles y violentos.
La culpa no es de los desarrolladores, sino de lo chapucerillos que son los desarrolladores del SDK.
Un saludo.