PDA

Ver la Versión Completa : Tutorial Solución a mensaje "Error de cámara" o brick de la cámara


v3rtik4l
01/02/11, 21:42:48
Buenas gente!

Después de pelearme 3 horas con internet, he conseguido solucionar aquellos que muchos decían que no tenía solución y que la única era mandarlo al SAT.
"Solucionar el error de firmware de la cámara del Galaxy S".

Bien los pasos a seguir son estos:

-> Descargar Es Explorador de archivos del market.
http://chart.apis.google.com/chart?cht=qr&chs=135x135&chl=market%3a%2f%2fdetails%3fid%3dcom.estrongs.and roid.pop%26referrer%3dutm_source%253DAndrolib%2526 utm_medium%253DPage%2526utm_campaign%253DAndrolib% 2520Page
-> Ir a configuración -> Opciones Root y activar ambas opciones.

-> Descargar Firmware de la cámara de nuestro hermano pequeño "Samsung Wave"
http://forum.xda-developers.com/attachment.php?attachmentid=443793&d=1290069404

-> Sobreescribir los archivos del Zip en la carpeta System/Firmware con "Es Explorador de archivos"

-> Marcar *#34971539# y elegir opción Phone to CAM FW Write

-> Reiniciar

Espero que a alguien más le sirva porqué a mi me ha costado encontrar la solución.

Solución sacada de http://forum.xda-developers.com/showthread.php?t=829482&page=3

1 Saludo.
Para cualquier aclaración o mejora de la solución, hacédmelo saber.

intronauta
01/02/11, 21:48:35
Gran noticia!!!

manda huevos que poniendo los binarios del samsung wave funcione y con los de un galaxy s no :S

subido el firmware a megaupload: http://www.multiupload.com/XSIZZ5KLEV

v3rtik4l
02/02/11, 03:58:23
Espero que este post no caiga en el olvido.. porque he leído que mucha gente tiene ese problema y ha tenido que mandar el móvil al SAT, lo que significa 20-25 días sin el Galaxy..

Si pudiera alguien colgarlo en el recopilatorio de tutoriales podría servir en un futuro para algo y alguien.

Gracias ^^ :aplausos:

Miorat
02/02/11, 07:44:55
Espero que este post no caiga en el olvido.. porque he leído que mucha gente tiene ese problema y ha tenido que mandar el móvil al SAT, lo que significa 20-25 días sin el Galaxy..

Si pudiera alguien colgarlo en el recopilatorio de tutoriales podría servir en un futuro para algo y alguien.

Gracias ^^ :aplausos:

Que error es ese??? a mi nunca me ha pasado.

De todas formas, y hablando desde la ignorancia... con el upgrade tools - Hacked Camera del SGS tools no se solucionaría también???

vvaleta
02/02/11, 09:27:09
Luego lo subo al hilo de tutos, gracias compi.

mikitio
02/02/11, 09:32:41
enhorabuena....yo lo envié al SAT¡¡

joaquimjose
02/02/11, 09:33:09
Estupendo :ok::platano:. Muchas gracias tengo dos y uno de ellos el de mi conyuge lo tenia con la camara brikeada y por pereza de quedarnos sin el no lo habia llevada al sat.

Lorse
02/02/11, 09:46:34
Joer y luego resulta que los wave, al actualizar el firmware de la cámara, algunos la brickeaban también
Al final resultará que lo mismo se equivocaron y han mezclado los firmware de los 2 modelos :facepalm:

Gran aporte :ok:

BeR10
10/02/11, 15:23:28
Voy a probarlo que estoy hasta los huevos del error de la cámara siempre que necesito hacer una foto.

tanazu
10/02/11, 15:30:04
Que error es ese??? a mi nunca me ha pasado.

De todas formas, y hablando desde la ignorancia... con el upgrade tools - Hacked Camera del SGS tools no se solucionaría también???
Eso es para que el botón de disparo de la cámara sea el del power

BeR10
10/02/11, 15:31:20
Vale, lo he hecho, y nada, abre la aplicación cámara, esta 1-2 seg con la pantalla en negro y sale el error.
No sé que hacer, y la verdad que me jodería mucho mandarlo al sat.

PD: Voy a probar a flashear con odin a alguna rom. A ver si hace algo.

BeR10
10/02/11, 17:22:45
Nada, sigue igual.
Antes por lo menos podía de vez en cuando hacer alguna foto.
Pero desde que hize lo del primer post. Abro la cámara está unos segundos con la pantalla en negro y salta el error. No sé, es raro. Lo que se me pasó es guardar los archivos originales por si acaso antes de sobreescribirlos.

¿Alguien podría pasarme los archivos originales? :D

Gracias!

PD: Esto es raro raro raro raro, he vuelto a escribir el firmware de la cámara y ahora parece que la cámara vuelve a funcionar. Lo dicho, raro raro raro raro.
PD2: He vuelto a abrir la cámara y ha vuelto a dar error.... que ruina...
PD3: El tema es que si apago el teléfono y le vuelvo a encender, la cámara vuelve a funcionar.... hasta que peta otra vez, pero en ese tiempo me deja hacer fotos y grabar vídeos. Ésto nunca me había pasado con un teléfono jajaj.

rafalense
10/02/11, 20:38:54
Nada, a mi me sigue dando 'Error de cámara'

Estaba en JS3, se me cascó probando el fw del wave

He flasheao JS5, y nada

He probado todo lo que dicen aquí:

http://www.htcmania.com/showthread.php?t=150073&page=7

Y todo lo de aquí:

http://forum.xda-developers.com/showthread.php?t=829482

:(

pedroomnia
10/02/11, 21:04:46
A mi me pasó esto ayer.Pantalla en negro para fotos y vídeo con mensajito de error. Primero me baje los drivers de megauload luego actualice el firmware. No me funcionó. Puse la rom jpu con repartición e hice la misma operación pero sin copiar drivers esta vez. Actualicé el firmware de la cámara y se arreglo.


Suerte.

Sent from my GT-I9000 using Tapatalk

rafalense
10/02/11, 21:15:32
JUUUUUUUUUURRR!

Estos bin del 23/07/2010 sí me han funcionado

http://www.multiupload.com/SMWZI7MX90

Lo normal: Meter en 'system/firmware', hacer un 'phone to cam write' y reboot

Ya de paso, como ese es un fw antiguo, aquí os paso una actualización oficial que aparece por lo visto en Samsung Apps para Canada. Probado en mi i9000, perfecto. Dicen que hace autofocus al grabar video:

http://www.4shared.com/file/estcwRQU/comsecandroidappcamerafirmware.html

Post original de xda: http://forum.xda-developers.com/showthread.php?t=905502

dejong
10/02/11, 23:01:14
que bien me hubiera venido para no mandarlo al sat cuando me pasó.....

v3rtik4l
11/02/11, 00:50:00
Yo por eso.. estuve 4 horas... buscando la solución, probando de todo, hasta que encontré esa solución y chapó.. ^^

Yo paso de probar más firmwares que ya tuve bastante con estar 1 semana sin cámara... jajaja que se quede así, el autofocus.. me da igual xDDD

Salu2

BeR10
11/02/11, 10:55:26
Pues yo no entiendo que le pasa a mí teléfono.
Lo normal sería que funcionara la cámara bien o no funcionara.
Pero a mi me funciona a veces sí y otras no :S
¿Esto le pasa a alguien?
No veo normal que este un rato haciendo fotos/vídeos, quite la cámara y cuando quiera volver a hacer fotos/vídeos salte el error.
¿Puede que haya algo que machaque la cámara?
Dudo que el problema sea de hardware... más bien de software, pero he probado todo lo que habéis puesto aquí y sigue igual.... Funciona a ratos.... xD

pedroomnia
11/02/11, 12:35:35
Has mirado que no sea problema de la tarjeta de memoria?

Sent from my GT-I9000 using Tapatalk

BeR10
11/02/11, 12:42:41
No tengo tarjeta de memoria. :(

BeR10
13/02/11, 10:57:51
Al final me doy por vencido. No sé que más probar. Y eso que el teléfono me va de fábula...
Habrá que mandarle al SAT.

Bueno, esto ya como última intentona. Si alguien que le funcione bien la cámara es tan amable de pasarme sus archivos .bin de System/firmware y si me pasa la aplicación camara.apk y camarafirmware.apk le estaría muy agradecido :)

javier5221
13/02/11, 15:13:50
He tenido problemas con la cámara casi desde que lo tuve en mis manos con el mensajito de Error en la Cámara y siguiendo este proceso de modificar el firmware original con el del Wave al menos he conseguido hacerla funcionar, eso si, con aplicaciones externas tipo camera360 o camera FX ya que la aplicación original del móvil sigue dando el mismo mensaje pero al menos ya sé que la cámara funciona.
Muchas gracias.

BeR10
13/02/11, 16:19:41
He tenido problemas con la cámara casi desde que lo tuve en mis manos con el mensajito de Error en la Cámara y siguiendo este proceso de modificar el firmware original con el del Wave al menos he conseguido hacerla funcionar, eso si, con aplicaciones externas tipo camera360 o camera FX ya que la aplicación original del móvil sigue dando el mismo mensaje pero al menos ya sé que la cámara funciona.
Muchas gracias.

Y con las otras aplicaciones no te ha dado error?
Por ejemplo, a mí me da error la cámara, con la aplicación del teléfono, si abro por ejemplo el camera360 me dice que ha habido un error y no se qué.

Si usas siempre una aplicación de terceros no da error?

javier5221
13/02/11, 18:59:55
Haber, querido Ber10, hace tiempo, concretamente el 16/12/2010 inicie un tema que podrás encontrar sin problemas en el que detallo el calvario que tuve que vivir con el uso de la cámara y como apliqué todas las soluciones que aportaron en distintos foros a los que acudí.
Ya me había dado por vencido y tenía asumido que tendría que acudir al SAT, pero al haber trasteado el móvil con todo tipo de Rom's y demás pues lo tenía aparcado el tema ( llevo dos móviles encima y utilizo la cámara del segundo) de hecho, hacía bastante tiempo que no visitaba el foro, pero hoy me he encontrado con la solución que tan amablemente nos ha dejado el compañero v3rtik4l y al seguirla al pie de la letra (bueno yo he utilizado el "root explorer" en lugar de "Es Explorador de archivos", para el caso es lo mismo) se ha producido el milagro de que la cámara ahora si que está disponible, es verdad que si ejecuto la aplicación original sigue dándome error, en eso no ha habido ningún cambio pero me permite utilizar aplicaciones del tipo: Camera360, FxCamera, camera Advance, Sleek Camera e , incluso, puedo utilizar el Barcode Scanner cosa que antes no era posible, en fin, "toi" muy contento aún a sabiendas de que la funcionalidad de la cámara no sea completa al menos puedo sacar fotos que es de lo que se trata. Saludos.

vinclar
13/02/11, 19:06:07
Os dejo la app para actualizar el firmware de la cámara de samsung, sacada de xda.
Esta se instala, mira si el fw necesita actualizarse y tras actualizar se desinstala.

circulotecno
19/02/11, 22:46:31
Hola, tmb me compre un galaxy s i9000t y me da este error en la camara. "Error de camara" pero cuando intento sobreescribir los archivos del zip en la carpeta system/firmware con "es explorador de archivos" me sale un mensaje que dice "peligro!!! ¿desea sobreescribirlo?(carpeta sera fusionada) y cuando le le pongo aceptar me sale un mensaje que dice "fallo al copiar"

JamworkS
19/02/11, 22:51:03
Hola, tmb me compre un galaxy s i9000t y me da este error en la camara. "Error de camara" pero cuando intento sobreescribir los archivos del zip en la carpeta system/firmware con "es explorador de archivos" me sale un mensaje que dice "peligro!!! ¿desea sobreescribirlo?(carpeta sera fusionada) y cuando le le pongo aceptar me sale un mensaje que dice "fallo al copiar"
Compañero empiezas con mal pie en el foro. Primero, primer mensaje en el foro y no es para presentarse que es lo único que pedimos que la gente haga en este foro, puedes hacerlo aquí: //www.htcmania.com/forumdisplay.php?f=43 (http://www.htcmania.com/forumdisplay.php?f=43)

Luego, escribes en mayúsculas y en negrita, lo que se considera de muy mala educación.

Así, que trata de tener más cuidado, sobre todo con ésto último, la próxima vez por favor :ok:.

circulotecno
19/02/11, 23:19:12
jaja, mil disculpas Jamworks es que recien me suscribi y estoy un poco perdido!! gracias por el link ya me presente. agradeceria que me dieran una mano con esta duda porque ya nose que mas hacer para que funcione la cam de mi galaxy s!! "el problema tambien se da cuando abro cualquier aplicacion que requiera la camara". (http://www.htcmania.com/member.php?u=118)

JamworkS
19/02/11, 23:22:06
Bueno, compañero, ten algo de paciencia a ver si algún compi que tenga una galaxy te echa un cable ;-).

juacas
22/02/11, 10:05:01
He tenido problemas con la cámara casi desde que lo tuve en mis manos con el mensajito de Error en la Cámara y siguiendo este proceso de modificar el firmware original con el del Wave al menos he conseguido hacerla funcionar, eso si, con aplicaciones externas tipo camera360 o camera FX ya que la aplicación original del móvil sigue dando el mismo mensaje pero al menos ya sé que la cámara funciona.
Muchas gracias.

En mi caso me ocurre justo al contrario. He recuperado (en apariencia totalmente) el firmware de la cámara con los ficheros del Wave. Funciona la aplicación de cámara nativa del Galaxy pero no puedo utilizarla con ninguna de las otras aplicaciones que mencionas.

juacas
22/02/11, 17:05:43
Solución a otro problema con la cámara; para alucinar!

En mi caso, tras reinstalar el firmware de cámara, ninguna aplicación salvo la original de Samsung podía acceder a la cámara...
Resulta que tenía desactivado con Autoruns el autoarranque del programa email.apk (el cliente de correo por defecto) porque yo uso K9mail y resulta que si no se ejecuta esta aplicación al inicio del teléfono (aunque no se configure ni se haga nada con él) no se puede utilizar la cámara utilizando las funciones estándar de Android.

¿alguien le ve alguna lógica a este efecto colateral?

Referencia de la solución: http://forum.xda-developers.com/showthread.php?p=11545384#post11545384

Unnamed Reloaded
28/02/11, 17:40:05
Que mejor forma de estrenarme en esta gran comunidad que dando las gracias a v3rtik4l por su magnifico turorial, el cual me ha funcionado al 100%!

1000 gracias amigo!
(http://www.htcmania.com/member.php?u=423047)

latzu
01/03/11, 13:10:55
hola a todos.

tengo un problema, no encuentro la carpeta system/firmware con el se explorador.

alguien me puede guiar un poco mas. sere torpe. gracias a todos

latzu
01/03/11, 13:26:55
lo e hecho pero con el root explorer. pero cuando le doy phone to cam fw whrite
me dice failed, a alguien le pasa igual? que puedo hacer

daviz666
13/03/11, 23:56:38
Buenas gente!

Después de pelearme 3 horas con internet, he conseguido solucionar aquellos que muchos decían que no tenía solución y que la única era mandarlo al SAT.
"Solucionar el error de firmware de la cámara del Galaxy S".

Bien los pasos a seguir son estos:

-> Descargar Es Explorador de archivos del market.
http://chart.apis.google.com/chart?cht=qr&chs=135x135&chl=market%3a%2f%2fdetails%3fid%3dcom.estrongs.and roid.pop%26referrer%3dutm_source%253DAndrolib%2526 utm_medium%253DPage%2526utm_campaign%253DAndrolib% 2520Page
-> Ir a configuración -> Opciones Root y activar ambas opciones.

-> Descargar Firmware de la cámara de nuestro hermano pequeño "Samsung Wave"
http://forum.xda-developers.com/attachment.php?attachmentid=443793&d=1290069404

-> Sobreescribir los archivos del Zip en la carpeta System/Firmware con "Es Explorador de archivos"

-> Marcar *#34971539# y elegir opción Phone to CAM FW Write

-> Reiniciar

Espero que a alguien más le sirva porqué a mi me ha costado encontrar la solución.

Solución sacada de http://forum.xda-developers.com/showthread.php?t=829482&page=3

1 Saludo.
Para cualquier aclaración o mejora de la solución, hacédmelo saber.



MIL GRACIAS!!!!! Casi me da un infarto, me has salvado la vida. funciono perfectamente!

v3rtik4l
14/03/11, 00:28:03
Que mejor forma de estrenarme en esta gran comunidad que dando las gracias a v3rtik4l por su magnifico turorial, el cual me ha funcionado al 100%!

1000 gracias amigo!

MIL GRACIAS!!!!! Casi me da un infarto, me has salvado la vida. funciono perfectamente!

De nada chicos, me alegro que mi búsqueda pudiera ayudar a más personas en mi situación.. ^^

Saludos

v3rtik4l
14/03/11, 00:29:18
lo e hecho pero con el root explorer. pero cuando le doy phone to cam fw whrite
me dice failed, a alguien le pasa igual? que puedo hacer

Tienes puesto el Sistema en modo r/w ? No se si podrá eso porque nunca me ha dado fallo en ese paso.. si quiers te lo busco si todavía no encontrastes una solución.. ^^

Salu2

ABM777
20/03/11, 14:02:55
JUUUUUUUUUURRR!

Estos bin del 23/07/2010 sí me han funcionado

http://www.multiupload.com/SMWZI7MX90

Lo normal: Meter en 'system/firmware', hacer un 'phone to cam write' y reboot

Ya de paso, como ese es un fw antiguo, aquí os paso una actualización oficial que aparece por lo visto en Samsung Apps para Canada. Probado en mi i9000, perfecto. Dicen que hace autofocus al grabar video:

http://www.4shared.com/file/estcwRQU/comsecandroidappcamerafirmware.html

Post original de xda: http://forum.xda-developers.com/showthread.php?t=905502
Una pregunta, he actualizado correctamente con la del Wave, alguien sabe que funcionalidades pierde la camara? a ver si voy a tener una camara peor que la que tenia de fabrica, lo digo por meterlos esos bin que parecen que son mas actualizados o la actualizacion oficial que hace autofocus al grabar video

Ayuda please

ABM777
20/03/11, 17:31:09
subo a ver si alguien me echa una mano con el firm

kingstral
26/03/11, 22:45:52
Hola, tengo el mismo problema con la hts desire..ni la camra ni el falsh me van desde una room q meti..no hay manera de q funcione, ni con rooms, cambiando radio, hard reset..no hay forma...
me podeis echar un cable ??

enano24280
29/03/11, 23:40:30
Hola gente. Me gustaría aportar una solución que he encontrado hoy. Ayer actualicé a 2.3.3 JVK y esta mañana al intentar poner lo del botón de power para la cámara coon el SGS Tools la cámara me ha dejado de funcionar. Se abría, le daba a hacer foto pero nada, un rato la pantalla en negro y se cerraba con el correspondiente error. Bueno pues me he descargado el Captivate SGS Tools (parece el SGS Tools pero cambian cosas), y en Apply script hay varias opciones para restaurar diferentes cosas. Una de ellas es restore_camer.txt (creo recordar que es así). Bueno pues se da ahí y listo. La cámara me ha vuelto a funcionar después de seguir unos cuantos tutoriales, entre ellos este al que hay que estar muy agradecido, y de leer en mil foros. Espero haber sido de ayuda. Un saludo

ABM777
30/03/11, 17:25:49
Hola gente. Me gustaría aportar una solución que he encontrado hoy. Ayer actualicé a 2.3.3 JVK y esta mañana al intentar poner lo del botón de power para la cámara coon el SGS Tools la cámara me ha dejado de funcionar. Se abría, le daba a hacer foto pero nada, un rato la pantalla en negro y se cerraba con el correspondiente error. Bueno pues me he descargado el Captivate SGS Tools (parece el SGS Tools pero cambian cosas), y en Apply script hay varias opciones para restaurar diferentes cosas. Una de ellas es restore_camer.txt (creo recordar que es así). Bueno pues se da ahí y listo. La cámara me ha vuelto a funcionar después de seguir unos cuantos tutoriales, entre ellos este al que hay que estar muy agradecido, y de leer en mil foros. Espero haber sido de ayuda. Un saludo
Muchas gracias por la informacion, la verdad es que me ha servido de ayuda, porque tenia la del wave instalada porque la lie al borrar el programa "email" (con eso se jodia la camara por lo vist) y el firmware digamos que no me tenia con la mosca en la oreja porque hacia las fotos sin el focus, me daba a mi la sensacion que de peor calidad.....ahora he puesto lo que has dicho y va perfecto, como antes, parece que echa las fotos con mas definicion y enfocando mejor

Ademas el programa tambien me ha servido para quitar el sonido de inicio del movil, que era algo innecesario totalmente

enano24280
30/03/11, 20:07:30
Muchas gracias por la informacion, la verdad es que me ha servido de ayuda, porque tenia la del wave instalada porque la lie al borrar el programa "email" (con eso se jodia la camara por lo vist) y el firmware digamos que no me tenia con la mosca en la oreja porque hacia las fotos sin el focus, me daba a mi la sensacion que de peor calidad.....ahora he puesto lo que has dicho y va perfecto, como antes, parece que echa las fotos con mas definicion y enfocando mejor

Ademas el programa tambien me ha servido para quitar el sonido de inicio del movil, que era algo innecesario totalmente


Me alegro de haber sido de ayuda. Además he comprobado que hay más gente a la que esta solución le ha solventado el problema. Un saludo.

rubentrial
31/03/11, 00:58:26
Hola gente. Me gustaría aportar una solución que he encontrado hoy. Ayer actualicé a 2.3.3 JVK y esta mañana al intentar poner lo del botón de power para la cámara coon el SGS Tools la cámara me ha dejado de funcionar. Se abría, le daba a hacer foto pero nada, un rato la pantalla en negro y se cerraba con el correspondiente error. Bueno pues me he descargado el Captivate SGS Tools (parece el SGS Tools pero cambian cosas), y en Apply script hay varias opciones para restaurar diferentes cosas. Una de ellas es restore_camer.txt (creo recordar que es así). Bueno pues se da ahí y listo. La cámara me ha vuelto a funcionar después de seguir unos cuantos tutoriales, entre ellos este al que hay que estar muy agradecido, y de leer en mil foros. Espero haber sido de ayuda. Un saludo
Buenas noches, pero cuando le das a restor_camer.txt aparece una pantalla en la que pone "All done! press back key now" con un circulo a su izquierda dando vueltas como si lo estuviese ejecutando pero no se para, hay que volver para atras, ¿es asi? y gracias de antemano

rubentrial
31/03/11, 01:10:08
Hola gente. Me gustaría aportar una solución que he encontrado hoy. Ayer actualicé a 2.3.3 JVK y esta mañana al intentar poner lo del botón de power para la cámara coon el SGS Tools la cámara me ha dejado de funcionar. Se abría, le daba a hacer foto pero nada, un rato la pantalla en negro y se cerraba con el correspondiente error. Bueno pues me he descargado el Captivate SGS Tools (parece el SGS Tools pero cambian cosas), y en Apply script hay varias opciones para restaurar diferentes cosas. Una de ellas es restore_camer.txt (creo recordar que es así). Bueno pues se da ahí y listo. La cámara me ha vuelto a funcionar después de seguir unos cuantos tutoriales, entre ellos este al que hay que estar muy agradecido, y de leer en mil foros. Espero haber sido de ayuda. Un saludo
¿hay que hacer algo de lo que dice v3rtik4l antes de realizar tus pasos?

ABM777
31/03/11, 01:50:35
Buenas noches, pero cuando le das a restor_camer.txt aparece una pantalla en la que pone "All done! press back key now" con un circulo a su izquierda dando vueltas como si lo estuviese ejecutando pero no se para, hay que volver para atras, ¿es asi? y gracias de antemano
Con eso es que ya esta instalado, no tienes que esperar que ese circulo pare de dar vueltas (porque no para de dar vueltas nunca vaya)

rubentrial
31/03/11, 08:35:19
Con eso es que ya esta instalado, no tienes que esperar que ese circulo pare de dar vueltas (porque no para de dar vueltas nunca vaya)
Gracias,¿pero no hay que instalar nada antes?

joaothomas
31/03/11, 10:09:10
Con "Error de la cámara" os referís a que, al hacer una foto, es como si por algún error no captara la imagen y os sale en la galería una especie de icono gris? Porque a mi es lo que me pasa, y me pasa con varios FW, he probado a cambiarlos pero nada... Sin embargo haciendo fotos si funciona, y a veces si hace las fotos, sobre todo recién reiniciado, pero luego es como decís, se jode (pero no me da ningún mensaje de error, y sí puedo grabar vídeos que es lo que me mosquea...)

Ayuda! :(

rubentrial
31/03/11, 20:48:59
No me funciona ¿Hay que instalar algo antes para sustituirlo?

Masterpaco3
31/03/11, 20:52:03
Hola gente. Me gustaría aportar una solución que he encontrado hoy. Ayer actualicé a 2.3.3 JVK y esta mañana al intentar poner lo del botón de power para la cámara coon el SGS Tools la cámara me ha dejado de funcionar. Se abría, le daba a hacer foto pero nada, un rato la pantalla en negro y se cerraba con el correspondiente error. Bueno pues me he descargado el Captivate SGS Tools (parece el SGS Tools pero cambian cosas), y en Apply script hay varias opciones para restaurar diferentes cosas. Una de ellas es restore_camer.txt (creo recordar que es así). Bueno pues se da ahí y listo. La cámara me ha vuelto a funcionar después de seguir unos cuantos tutoriales, entre ellos este al que hay que estar muy agradecido, y de leer en mil foros. Espero haber sido de ayuda. Un saludo

Muchas gracias compañero, me pasaba igual que a ti, queriendo aplicar el hack a la camara, me dio error y no podia hacer foto, pero con este programa solucionado. Ahora bien, en 2.3.3 no se puede poner el hack a la camara?

Gracias de antemano!

enano24280
31/03/11, 22:13:56
No me funciona ¿Hay que instalar algo antes para sustituirlo?

Si tu error de la camara es por haber intentado aplicar el hacker camara del SGS tools para hacer fotos con el boton power debería solucionarse así. Si es otro error o has hecho alguna modificación entonces ya no lo se.

enano24280
31/03/11, 22:17:25
Muchas gracias compañero, me pasaba igual que a ti, queriendo aplicar el hack a la camara, me dio error y no podia hacer foto, pero con este programa solucionado. Ahora bien, en 2.3.3 no se puede poner el hack a la camara?

Gracias de antemano!

Por lo que he podido investigar (navegando por los foros ya que no soy ningún experto), de momento creo con 2.3.3 tendremos que seguir haciendo las fotos con la pantalla táctil. Pero seguro que alguno de los artistas que hay por aquí lo soluciona pronto.

ABM777
31/03/11, 22:23:40
No me funciona ¿Hay que instalar algo antes para sustituirlo?
No, nada antes, solo esos pasos y te deberia de funcionar, sino al SAT que tiene garantia y ya esta
Por lo que he podido investigar (navegando por los foros ya que no soy ningún experto), de momento creo con 2.3.3 tendremos que seguir haciendo las fotos con la pantalla táctil. Pero seguro que alguno de los artistas que hay por aquí lo soluciona pronto.
Yo con la camara ya no toco absolutamente nada, quien me iba a decir que por quitar el programa "email" del movil las camaras se jodian, bastante pase para meter el firm del wave y tener con ese firm una camara peor que esta :risitas::risitas:

enano24280
31/03/11, 22:29:31
Yo con la camara ya no toco absolutamente nada, quien me iba a decir que por quitar el programa "email" del movil las camaras se jodian, bastante pase para meter el firm del wave y tener con ese firm una camara peor que esta :risitas::risitas:

Y que lo digas, yo tampoco. Si es que es superior a nosotros el estar urgándole al móvil! y luego mira lo que pasa... jajaja

rubentrial
02/04/11, 15:12:03
Creo que me queda mi primo que tiene un galaxi y controla o sat, gracias a todos.

rubentrial
02/04/11, 15:15:23
Si tu error de la camara es por haber intentado aplicar el hacker camara del SGS tools para hacer fotos con el boton power debería solucionarse así. Si es otro error o has hecho alguna modificación entonces ya no lo se.
No no fue por aplicar el hacker camara SGS tools para hacer fotos no el boton power, empezo un dia asi y no se porque pero ha ido a mas y ahora no hay manera, un saludo.

pintxoj
07/04/11, 19:10:53
Hola gente. Me gustaría aportar una solución que he encontrado hoy. Ayer actualicé a 2.3.3 JVK y esta mañana al intentar poner lo del botón de power para la cámara coon el SGS Tools la cámara me ha dejado de funcionar. Se abría, le daba a hacer foto pero nada, un rato la pantalla en negro y se cerraba con el correspondiente error. Bueno pues me he descargado el Captivate SGS Tools (parece el SGS Tools pero cambian cosas), y en Apply script hay varias opciones para restaurar diferentes cosas. Una de ellas es restore_camer.txt (creo recordar que es así). Bueno pues se da ahí y listo. La cámara me ha vuelto a funcionar después de seguir unos cuantos tutoriales, entre ellos este al que hay que estar muy agradecido, y de leer en mil foros. Espero haber sido de ayuda. Un saludo

Hola! Tenia el error de camra al nada de encenderla, y con esto se me ha quitado (gracias!! :ok: ), pero ahora al poner la camara la pantalla parpadea ahora cada 10 o 15 segundos lo cual es bastante molesto por no decir que no te deja enfocar bien una foto... que me recomendais??

Saludos!!

EDITO: Nada, sigo con "error de camara" probare con la solucion del primer post. ya os dire

pinep
07/04/11, 20:17:03
quien me iba a decir que por quitar el programa "email" del movil las camaras se jodian, bastante pase para meter el firm del wave y tener con ese firm una camara peor que esta :risitas::risitas:

Joer ya podía volverme loco yo! A mi también me pasa que me zepille el email.apk!

En cuanto carge la batería a tope reflaseo a ver si se arregla la camara...

pintxoj
08/04/11, 11:00:38
Bueno finalmente todo el movil se me habia vuelto un poco loco, los videos se me pausaban cada minuto, la camra me daba error, y la gente me oia como si estuviera en la radio xD

Solucion: Wipe y restaurar. Ahora todo ok. Camara ok. Movil ok. :ok:

Saludos y gracias de nuevo a los que crearon este post!

pinep
08/04/11, 13:09:34
Yo lo he solucionado re-flaseando la 2.3.3 y ademas me he puesto la criskelo v25 que trae la camara hack y ya esta todo solucionado.

En mi caso el fallo fue por eliminar el email.apk

migui7
25/04/11, 02:00:05
Gracias amigo, me ha valido tu solucion.

Gracias!

rubentrial
25/04/11, 06:59:05
Os dejo la app para actualizar el firmware de la cámara de samsung, sacada de xda.
Esta se instala, mira si el fw necesita actualizarse y tras actualizar se desinstala.

Parece que con estas indicaciones funciona de momento, gracias

jmax galaxy S
25/04/11, 08:00:03
A mí lo que me mosquea es que muchas veces me da error al grabar vídeo desde que actualicé el firmware con el codigo secreto... A los pocos minutos de empezar me suele dar error de "resolución no soportada" (720p) o sencillamente se para y deja de grabar... estoy algo mosqueado porque lo que es las fotos las echa de lujo, pero con los vídeos no se lleva bien mi galaxy... así que no sé si me compensaría probar con otros firmwares. La aplicación "camera firmware" me dice que ya tengo la última instalada.

v.franco1
02/05/11, 10:13:04
Buenas. A mi no me deja acceder a root y aceptar las 2 opciones.
Tengo GalaxyS con Froyo. Gracias

taopaipai
17/05/11, 19:34:04
JUUUUUUUUUURRR!

Estos bin del 23/07/2010 sí me han funcionado

http://www.multiupload.com/SMWZI7MX90

Lo normal: Meter en 'system/firmware', hacer un 'phone to cam write' y reboot

Ya de paso, como ese es un fw antiguo, aquí os paso una actualización oficial que aparece por lo visto en Samsung Apps para Canada. Probado en mi i9000, perfecto. Dicen que hace autofocus al grabar video:

http://www.4shared.com/file/estcwRQU/comsecandroidappcamerafirmware.html

Post original de xda: http://forum.xda-developers.com/showthread.php?t=905502


@rafalense (http://www.htcmania.com/member.php?u=34561)

Veo que has llegado incluso a crear un varios hacks para la cámara. Muchas gracias.:ok:

Pero repasando este hilo, después de leer tu comentario de que sólo te había funcionado ese FW de julio de 2010, me pregunto cómo lo haces. ¿Cada vez que cambias de rom (incluyendo ginger) tienes que utilizar ese o también te han funcionado otros?

Saludos.

sapolini
17/05/11, 22:29:09
A mi se me ha jodido asi porque si, ella sola.

Ayer instale la 2.3.3 y esta mañana me ha funcionado sin problemas. Y justo ahora hace un rato voy a hacer una foto y zasca. Petao... y la verdad que no quiero hacer otra vez un wipe despues de tirarme toda la tarde metiendo contraseñas y historias al movil...

Alguna solucion para este caso?

PD: No tengo root, y con el superoneclick que tenia antes he leido que no puedo en la oficial 2.3.3 para NEE

caminador
23/05/11, 09:10:19
Buenas gente!

Después de pelearme 3 horas con internet, he conseguido solucionar aquellos que muchos decían que no tenía solución y que la única era mandarlo al SAT.
"Solucionar el error de firmware de la cámara del Galaxy S".

Bien los pasos a seguir son estos:

-> Descargar Es Explorador de archivos del market.
http://chart.apis.google.com/chart?cht=qr&chs=135x135&chl=market%3a%2f%2fdetails%3fid%3dcom.estrongs.and roid.pop%26referrer%3dutm_source%253DAndrolib%2526 utm_medium%253DPage%2526utm_campaign%253DAndrolib% 2520Page
-> Ir a configuración -> Opciones Root y activar ambas opciones.

-> Descargar Firmware de la cámara de nuestro hermano pequeño "Samsung Wave"
http://forum.xda-developers.com/attachment.php?attachmentid=443793&d=1290069404

-> Sobreescribir los archivos del Zip en la carpeta System/Firmware con "Es Explorador de archivos"

-> Marcar *#34971539# y elegir opción Phone to CAM FW Write

-> Reiniciar

Espero que a alguien más le sirva porqué a mi me ha costado encontrar la solución.

Solución sacada de http://forum.xda-developers.com/showthread.php?t=829482&page=3

1 Saludo.
Para cualquier aclaración o mejora de la solución, hacédmelo saber.


por si a alguien le sirve yo he arreglado la camara con este metodo, haviendo flhaseado a la jvo y poniendo la ultima de criskelo anteriormente para ver si se arreglava y no conseguirlo , lo probe y funciono.
si que parece que las fotos y videos son de menor calidad, pero por lo demas todo correcto.

muchiiiiiiiiisimas gracias por tu ayuda :ok:

pd. me pregunto si funcionaria el firm del galasy s 2

john_smith
22/08/11, 14:48:06
bueno tengo el problema de la pantalla negra desde la 2.3.3 y ahora en la 2.3.4 y es permanente, he probado lo de cambiar el firm del wave y el otro pero nada, y el apk me dice que tiene la ultima version de firm aunque haya puesto la del wave, bien probe lo del sgs tools y es script y ahora me ha desaparecido la camara , me dice que no esta instalada esa aplicacion, alguna idea o tendre q restaurar a la rom de yoigo, mas lenta que el caballo del malo pero sin estas tonterias.
un saludo

john_smith
22/08/11, 15:40:24
bueno esto va de mal en peor , he instalado la 2.2.1 y la camara ya no funciona, de ninguna manera,alguna idea?....
alguien puede pasarme el ultimo firm para poner a mano pues lo que aparace en esta hilo ya no me sirve

skyblazer
31/10/11, 20:09:49
Buenísimo a funcionado a la primera tan solo que E/S Explorador de Archivos no me dejaba explorar las carpetas internas. Yo lo he hecho con Root Explorer para copiar los archivos a la carpeta System/firmware

goguito
25/12/11, 17:26:27
Buenas gente!

Después de pelearme 3 horas con internet, he conseguido solucionar aquellos que muchos decían que no tenía solución y que la única era mandarlo al SAT.
"Solucionar el error de firmware de la cámara del Galaxy S".

Bien los pasos a seguir son estos:

-> Descargar Es Explorador de archivos del market.
http://chart.apis.google.com/chart?cht=qr&chs=135x135&chl=market%3a%2f%2fdetails%3fid%3dcom.estrongs.and roid.pop%26referrer%3dutm_source%253DAndrolib%2526 utm_medium%253DPage%2526utm_campaign%253DAndrolib% 2520Page
-> Ir a configuración -> Opciones Root y activar ambas opciones.

-> Descargar Firmware de la cámara de nuestro hermano pequeño "Samsung Wave"
http://forum.xda-developers.com/attachment.php?attachmentid=443793&d=1290069404

-> Sobreescribir los archivos del Zip en la carpeta System/Firmware con "Es Explorador de archivos"

-> Marcar *#34971539# y elegir opción Phone to CAM FW Write

-> Reiniciar

Espero que a alguien más le sirva porqué a mi me ha costado encontrar la solución.

Solución sacada de http://forum.xda-developers.com/showthread.php?t=829482&page=3

1 Saludo.
Para cualquier aclaración o mejora de la solución, hacédmelo saber.


Hola, ya he conseguido cambiar los ficheros por los del wave con el file expert pero me sigue sin funcionar, también lo he intentado con el captivate sgs tools, le doy a restore cámera y me sale: cp:can't stat '/sdcard/sgstools2/camera*: no such file or directory

goguito
27/12/11, 02:03:29
Bueno, pues a mí no me ha funcionado ninguna de las soluciones anteriores pero en cuanto he flasheado a 2.3.4. o 2.3.5. ha vuelto a funcionar la puñetera cámara.X-D

jairniltonxD
11/05/12, 02:40:31
malparido hijo de la milputaa...... este link SIRVE SIRVE CSMR...... SIRVE.... NO SABES LO FELIZ K ME SIENTO DISCULPEN LAS GROSERIAS PERO ES LA UNICA MANERA D EXPRESAR LO FELIZ K SOY estube mas de 5 horAS SIN CAMARA NO SABIA K ACER YA LO IBA A ENVIAR A MALVINAS... ! PTMR K FELIZ K ESTOY SI FUERAS MUJER T BESARIA MEN EL K PUSO ESTE LINK... BUENO SIN MAS QUE DECIR GRACIAS .. Y SIGAN ASI SOY FIEL A HTC MANIA... ! GALAXY S GT I900

rodri9
24/10/12, 20:58:30
He hecho los pasos y cuando pongo cam fm write me pone failed! por que?:rolleyes:

magofita
29/12/12, 15:41:09
Yo lo he intentado unas 1000 veces y siempre me sale este mensaje al marcar el numero:
"Se ha producido un problema de conexión o el código MMI no es válido"
Echo muchísimo de menos la cámara de mi móvil, alguna solución a este mensajito?

Ahh! tengo android 4.2 (Beast Rom) he probado muchísimas Roms pero ninguna lo soluciona

weasleytona
10/01/13, 00:38:22
Ayudaa!!!
no se como se sobreescriben los archivos del zip en Es explorador de archivos!!
Alguien me puede decir como lo hago? es lo unico que me falta creeooooo PORFAVOR
:cry:

gti_nyl
08/08/13, 09:55:12
Hola, ya he conseguido cambiar los ficheros por los del wave con el file expert pero me sigue sin funcionar, también lo he intentado con el captivate sgs tools, le doy a restore cámera y me sale: cp:can't stat '/sdcard/sgstools2/camera*: no such file or directory


Refloto porque estoy en esta situación exactamente, alguien me ayuda?

realflaco1992
11/04/14, 09:06:43
no me sale la carpeta ayuda porfavor